CoDrone code Error



  • Hello CoDrone Team,

    I am trying to upload the default program to the controller, however there seems to be an issue with the code, potentially I am referencing the incorrect library or some other setting is off? I have checked and rechecked that I am using the correct port and that I'm using the right board. The error message I received is below, hope you can help!

    Arduino: 1.8.7 (Mac OS X), Board: "Rokit-SmartInventor-mega32_v2"
    
    /var/folders/zr/qk8zmyj16pd2ky1rzv_32smm0000gn/T/arduino_modified_sketch_801748/FlightController.ino: In function 'void setup()':
    FlightController:17:11: error: 'class CoDroneClass' has no member named 'pair'
       CoDrone.pair(Nearest);
               ^
    FlightController:17:16: error: 'Nearest' was not declared in this scope
       CoDrone.pair(Nearest);
                    ^
    /var/folders/zr/qk8zmyj16pd2ky1rzv_32smm0000gn/T/arduino_modified_sketch_801748/FlightController.ino: In function 'void loop()':
    FlightController:36:13: error: 'class CoDroneClass' has no member named 'emergencyStop'
         CoDrone.emergencyStop();
                 ^
    FlightController:42:14: error: 'class CoDroneClass' has no member named 'land'
          CoDrone.land();
                  ^
    FlightController:55:13: error: 'class CoDroneClass' has no member named 'move'
         CoDrone.move(ROLL,PITCH,YAW,THROTTLE);                  // Send the new flight commands
                 ^
    Multiple libraries were found for "CoDrone.h"
     Used: /Users/c-macv/Documents/Arduino/libraries/CoDrone
     Not used: /Users/c-macv/Documents/Arduino/libraries/arduino_945461
    exit status 1
    'class CoDroneClass' has no member named 'pair'
    /Users/c-macv/Documents/Arduino/libraries/arduino_945461/examples/Controller/FlightController/FlightController.ino
    
    This report would have more information with
    "Show verbose output during compilation"
    option enabled in File -> Preferences.
    


  • Hi @Currah! It looks like you may not have the latest CoDrone library downloaded in Arduino. Can you go to Sketch > Include Library > Library Manager..., then type "CoDrone" in the top right search bar after the window has finished loading.

    You should see version 2.1.1 as the version installed. If not, you'll need to be on the latest version to use the functions that are giving you errors.

    Give that a try, and let me know if you're still seeing the issue.



  • Hi @robolink_wes, thanks for the quick reply! I had version 2.1.1 installed, but I looked in the Arduino library folder and also had an older version of the CoDrone library installed that was being referenced by the code rather than v2.1.1. I moved the older version to the trash and everything worked smoothly. Thank you for alerting me to the potential library issues!



  • @Currah Great to hear! Glad you were able to have it resolved. Cheers!


Log in to reply
 

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.