library import issues on mac.



  • While trying to import CoDrone library I am having "module not found' error even after !pip3 install CoDrone says that all items are satisfied.

    //!pip3 install CoDrone
    Requirement already satisfied: CoDrone in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (1.2.5)
    Requirement already satisfied: pyserial in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from CoDrone) (3.4)
    Requirement already satisfied: colorama in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from CoDrone) (0.4.3)
    Requirement already satisfied: numpy in /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages (from CoDrone) (1.19.0)
    
    `import CoDrone---------------------------------------------------------------------------
    ModuleNotFoundError                       Traceback (most recent call last)
    <ipython-input-4-b794ab429015> in <module>
    ----> 1 import CoDrone
    
    /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/CoDrone/__init__.py in <module>
         11 
         12 
    ---> 13 from CoDrone.codrone import *
         14 from CoDrone.storage import *
         15 from CoDrone.system import *
    
    /Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/CoDrone/codrone.py in <module>
         11 from CoDrone.storage import *
         12 from CoDrone.protocol import *
    ---> 13 import matplotlib.pyplot as plt
         14 import time
         15

  • administrators

    @cpstjen Please run !pip3 install matplotlib as well. Our lesson page has just been updated to reflect this. Thank you for your question!


Log in to reply
 

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.