Ports are Gray'd out.



  • I'm pretty sure I've done everything, why is ports still grayed out?
    0_1521917778606_52a8d8ff-e9da-4c64-8734-b0e73d1f82b0-image.png
    0_1521917804339_743b9acb-c859-4908-ba78-5c19666e9078-image.png
    0_1521917822997_ac4cf997-4820-405a-9943-c4c668313d45-image.png
    0_1521917855990_d71f3003-deae-405c-ab42-5dab16495b90-image.png
    0_1521917900545_828a9c33-d201-4f18-8397-46e8ae47d4f6-image.png



  • The port should pop up once it detects the board. Are you sure you installed USB rivers?



  • Yeah, it shows you in the screenshot above. There are the USB drivers "ready to use". I try running it and do get this error.

    Arduino: 1.8.5 (Windows 10), Board: "Rokit-SmartInventor-mega32_v2"

    C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\mrste\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\mrste\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\mrste\OneDrive\Desktop\CoDrone\libraries -fqbn=rokit:avr:SmartInventor-mega32_v2 -ide-version=10805 -build-path C:\Users\mrste\AppData\Local\Temp\arduino_build_736050 -warnings=none -build-cache C:\Users\mrste\AppData\Local\Temp\arduino_cache_85597 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Users\mrste\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino5 -prefs=runtime.tools.avrdude.path=C:\Users\mrste\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.0.1-arduino5 -verbose C:\Users\mrste\OneDrive\Documents\Arduino\libraries\CoDrone\examples\Control\Controller_Flight\Controller_Flight.ino
    C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\mrste\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\mrste\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\mrste\OneDrive\Desktop\CoDrone\libraries -fqbn=rokit:avr:SmartInventor-mega32_v2 -ide-version=10805 -build-path C:\Users\mrste\AppData\Local\Temp\arduino_build_736050 -warnings=none -build-cache C:\Users\mrste\AppData\Local\Temp\arduino_cache_85597 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Users\mrste\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino5 -prefs=runtime.tools.avrdude.path=C:\Users\mrste\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.0.1-arduino5 -verbose C:\Users\mrste\OneDrive\Documents\Arduino\libraries\CoDrone\examples\Control\Controller_Flight\Controller_Flight.ino
    Using board 'SmartInventor-mega32_v2' from platform in folder: C:\Users\mrste\AppData\Local\Arduino15\packages\rokit\hardware\avr\1.0.3
    Using core 'atmega32' from platform in folder: C:\Users\mrste\AppData\Local\Arduino15\packages\rokit\hardware\avr\1.0.3
    Detecting libraries used...
    "C:\Users\mrste\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino5/bin/avr-g++" -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega32 -DF_CPU=7372800L -DARDUINO=10805 -DARDUINO_AVR_SMARTINVENTOR-MEGA32_V2 -DARDUINO_ARCH_AVR "-IC:\Users\mrste\AppData\Local\Arduino15\packages\rokit\hardware\avr\1.0.3\cores\atmega32" "-IC:\Users\mrste\AppData\Local\Arduino15\packages\rokit\hardware\avr\1.0.3\variants\SmartInventor" "C:\Users\mrste\AppData\Local\Temp\arduino_build_736050\sketch\Controller_Flight.ino.cpp" -o "nul"
    "C:\Users\mrste\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.8.1-arduino5/bin/avr-g++" -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega32 -DF_CPU=7372800L -DARDUINO=10805 -DARDUINO_AVR_SMARTINVENTOR-MEGA32_V2 -DARDUINO_ARCH_AVR "-IC:\Users\mrste\AppData\Local\Arduino15\packages\rokit\hardware\avr\1.0.3\cores\atmega32" "-IC:\Users\mrste\AppData\Local\Arduino15\packages\rokit\hardware\avr\1.0.3\variants\SmartInventor" "C:\Users\mrste\AppData\Local\Temp\arduino_build_736050\sketch\Controller_Flight.ino.cpp" -o "C:\Users\mrste\AppData\Local\Temp\arduino_build_736050\preproc\ctags_target_for_gcc_minus_e.cpp"
    C:\Users\mrste\OneDrive\Documents\Arduino\libraries\CoDrone\examples\Control\Controller_Flight\Controller_Flight.ino:5:89: fatal error: CoDrone.h: No such file or directory

    #include <CoDrone.h> // The codrone library that holds all the background files for this

                                                                                         ^
    

    compilation terminated.

    exit status 1
    Error compiling for board Rokit-SmartInventor-mega32_v2.


  • administrators

    @Matt-robins0n try switching the USB cable you are using. The grayed out part is indicating nothing is connected. Maybe the cable is providing power but not data.


  • Global Moderator

    Connect the usb dongle to the computer.
    Under your computer's search locate your device manager setting.
    Under the ports location there should be something along the lines of USB to UART(COM...)
    If you do not see this then your cable is not being recognized and you may have to switch out your USB cable.

    You may also need to try using a USB 2.0 port and NOT a USB 3.0 port(these are generally a blue port).


Log in to reply
 

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.